« 1979 Town Car Rear Main Seal Leak | Main | 1964 Turn Signal Issues - New Owner »

1976 Mark IV Blower Resistor Question

Hi Bill -

I'm having problems with my blower not working on Low speed but works OK on High speed. After reading some of the posts on your blog, I think I need to check the resistor module and associated plug. I've already checked the high blower relay on the firewall and found that it's working properly. My question is: Where is the resistor module located on my 1976 Mark IV ? Some of my friends have told me it's under the hood on the right side close to the fire wall. I haven't been able to locate it. My master parts catalog shows it to be under the dash but doesn't show exactly where it is.

Can you help me with this?

Curt

----------------------------------------------------------------------------------------------------------------

Greetings Curt -

The blower resistor and its connector area are excellent places to examine first with the low blower speed issue that you are experiencing at this time.

The resistor on your 76 Mark IV should be located up under the dash on the rt. side ( passenger side ) and mounted into the plenum assembly. It will be located between the transmission hump and the blower motor assembly. Removing the glove box liner should give you visual access and enough space to remove the resistor by releasing the necessary clips. If you require any replacement parts, we can supply them to you ASAP. Good luck to you with the inspection and the repair.

Sincerely,

Bill