« 1968 Automatic Temp Control Question | Main | 1969 Continental Sedan AC Questions »

1964 New Owner HVAC Issue

Hi Bill.

I have a problem with my HVAC control switch. It shorts when I adjust it, the fuse doesn't blow either which is a worry... I haven't investigated it yet as my car has only recently arrived in the UK. I only seems to have one speed and it only blows cold. Should I just look into replacing the unit or is there other things to investigate first.

Thanks.

Martin

----------------------------------------------------------------------------------------------------------------

Greetings Martin -

Congratulations on your recent 64 sedan purchase.

Why do you think you have a shorted circuit? What are the symptoms of a shorted circuit that you are seeing? Having only one speed on the blower indicates a problem but does not indicate a short. To answer your question, yes, there are other things to investigate before replacing all of the parts. Diagnosis is necessary before replacing any part in order to avoid replacing expensive parts that are already in good working order. Diagnosis should be performed with the use of the proper shop manual and wiring diagram. Have you spoken to the previous owner yet to find out what he or she knows regarding this issue?

Your symptom of " seems to have only one blower speed " indicates a possible faulty blower switch or blower resistor. I would check the blower controls and wiring etc. first. Look to see also if any one has bypassed a fuse or breaker or messed at all with the original factory installation . Good luck on an easy diagnosis and repair.

Sincerely,

Bill

----------------------------------------------------------------------------------------------------------------

Thanks for getting back to me Bill.

I think it has a short because if I move the fan speed switch lever it sparks. The previous owner said the air con didn't work, he hadn't investigated it though. There is a fresh cable that has be pushed into the fuse panel that doesn't have a fuse in. It may well be pushed into the battery side of the fuse and is always live.

Re the fan switch and resistor do you know what resistance I should expect?

Thanks for your help, I'm amazed how helpful the Lincoln community is.

Kind regards

Martin

----------------------------------------------------------------------------------------------------------------

Martin -

The blower switches on the 64-65 Lincolns can and do give problems. We see enough of them sent in here at Lincoln Land for repair that we are now able to rebuild or repair most of them. If as you posted that the switch lever itself is sparking when you move it, you will need to remove the switch for inspection. If you are looking into the actual switch contacts and seeing sparks, these sparks could be only the initial start up " draw " of the blower motor and compressor clutch. We do not have any resistance specs on any circuits. You can however do an amp draw test on your blower motor and compressor clutch coil. These specs in amps are usually shown in the factory service manuals. If the blower has a high out of spec electrical draw, the wiring and switch will suffer a slow melt down.

Before removing the blower switch I would first pull the blower motor resistor and inspect the coils and the wiring plug etc. for a possible contact problem. I have no idea what the "added on" wire is to the fuse box or where it leads to. If you are doing the actual work yourself you will definitely require the proper service manual and wiring diagrams. It looks like it is time to bring out the tool box. We wish you the best of luck.

Sincerely,

Bill