« 1979 Continental Sedan Battery Drain | Main | 1963 Lincoln Continental Running On After Being Turned Off »

1969 Mark III Leaking Oil, Follow Up and Reply....

Hello Bill,

My name is Gianni and I have a concern regarding my timing cover on my 460. I have the crank driven pump which I recently rebuilt and works great, and had replaced my timing cover with another because of some damage my original had. I took all precautionary steps to get a good seal on the cover, and cover to pump seal, but I have a rather large leak coming from this area. It looks to be coming from the back of the power steering pump and is definitely engine oil. I can still drive around, but have to check the level frequently. Do you know what could be wrong, the pump doesn't leak, but the seal behind it seems to be faulty?

Thanks

----------------------------------------------------------------------------------------------------------------

Greetings Gianni -

Several possibilities for your engine oil leak come to mind after reading your email. These are.... the crankshaft oil slinger was omitted during installation of the front cover. This could allow engine oil to scour the front seal with excess oil splash that the seal was never designed to handle. Next is the possibility of .......An incorrect or damaged front cover (at the seal area) was installed. This would cause a poor sealing situation. Another possibility is that the special seal between the front cover and the p/s pump was damaged, not installed at all or the original was not replaced with a new one and was already severely aged and ineffective after the removal and replacement procedure. What are the possibilities for any of the above suggestions?

Sincerely,

Bill

----------------------------------------------------------------------------------------------------------------

Bill -

It's hard to say? I installed a new rubber seal to the cover and made sure everything was prepped cleanly. Are 1969 covers different from those that have the 1968 year stamped on them? They looked exactly the same.

Gianni

----------------------------------------------------------------------------------------------------------------

It's hard for you to say?? It's even harder for me to say.....from here. The front covers for 460s with crank mounted p/s pumps should all be the same. Did we supply this cover or any other parts? The facts are that if every thing was prepped cleanly and assembled correctly and you have an oil leak at that area as you described, the pump will need to be removed again and that area inspected. Are you sure that the leak is not somehow coming from higher up from the rear of the pump? What about the possibility of the oil slinger omission that was suggested to you in my first reply?

Bill