« 1966 Continental Coupe Window Issues | Main | 1976 Mark IV Dash Disassembly Questions »

1966 Continental Coupe Running And Fuel Pump Issues

Hey Bill,

I was hoping you may be able to help. I have a 1966 Lincoln Continental Coupe dies when shifted out of park or neutral.

I am on my 3rd fuel pump and I am not sure what to do. The first 2 I had placed under the hood near the carburetor. This 3rd one I place right up on the tank by the outlet. It starts great, idols great shifts great then dies. UGGG!

Please help,
Thanks,

Troy

----------------------------------------------------------------------------------------------------------------

Hello Troy -

Sometimes these issues can be a challenge can't they. Your symptom of stalling when the transmission is engaged is a common complaint. The problem can be caused by many components however. The biggest failure in many of these repairs is "Incorrect Diagnosis". You seem to believe that you have a fuel delivery issue. Did anyone actually prove your belief with a proper fuel pump pressure and flow test as per the factory maintenance manual? Why do you think that you have a fuel delivery problem? These engines run real well with all of the factory fuel system parts in place and in good working order without electric pumps. Before performing ANY repair though you must be sure that you are on the right track with accurate diagnosis. You need to prove that the engine stalled because of lack of fuel to the carburetor. Because I cannot diagnose the cause from here I can only make some other suggestions for you to consider. Other causes of stalling when engaged in gear could be.......ALL basic carburetor set up and adjustments internal and external (very important), vital ignition maintenance and adjustments ( points, plugs and wires etc.) Be accurate in the diagnosis. Do not guess. Use the factory service manual for diagnosing.

If you do prove for sure that lack of fuel at the carburetor is the problem and that all of the fuel hoses and lines as well as the filters and the fuel tank inlet at the fuel sending unit and pick up in the tank are all o/k, send us an email in that regard and we will respond with more fuel system suggestions. Let us know what you find.

Sincerely,

Bill