« 1965 Interior Lighting Issues | Main | 1979 Mark AC Questions & Update »

1969 Mark Blower Motor Questions

Hello Bill,

First I want to thank you and your company for all of your assistance with parts and information on our 1969 Lincoln Mark III.

We are currently having problem with the heater / AC blower.

When running the AC, the fan blows on low speed only - No High
When running the Heat, the fan blows on low speed only - No High
changing over to the Defrost, the fan does not blow at all. -Neither low or high

Do you have any suggestions on where we should look for problems on this? It doesn't seem to switch over to defrost at all.

Thank you,

Terry

----------------------------------------------------------------------------------------------------------------

Greetings Terry -

We are pleased that you are happy with our service regarding parts and information. I can tell you that Lincoln Land and our staff certainly appreciate your business as well.

You don't state if your 69 Mark is equipped with the Automatic Climate Control or the Manual unit. Either way they both use a High Range relay located under the right fender near the hood hinge between the splash shield and fender. This relay would be the first item to test. It is a simple relay and its operation is shown in the Shop Manual and wiring schematics. We offer rebuilding service or replacements for these relays. If you feel that you do not have the skills or the proper manuals and wiring diagrams to do the necessary diagnosis we will offer to test your relay at no charge. If the relay is NOT found to be faulty further diagnosis may lead to issues in the main control switch, the ATC box and servo or their associated wiring. The above mentioned relay though is a very popular fail item and is by far the most logical part to inspect first.

Sincerely,

Bill