« 1969 Mark III Vacuum And Acceleration Issues | Main | 1967 Continental Coupe Possible Carb Issues »

1973 Continental Sedan Lighting Issues

Hi Bill,

My name is Steve and I have a nice '73 4D Continental.The problem I've been having goes something like this:

When I drive the car with the lights on for about 10 minutes something happens.All the lights (tail,dash,markers) with the exception of the headlights, start to go out and on again until I turn the lights off and wait a little and turn them back on.After a while it starts again.My guess is that something overheats in the circuit where those lights are connected and I checked the book and it says that there is some kind of a fuse built in the light switch to prevent overheating in the light circuit.If you could help me on this.

Thanks,

Steve

----------------------------------------------------------------------------------------------------------------

Greetings Steve,

The headlight switch has two circuit breakers within the unit. One is for the headlights and the other is for the dash,tail and marker lights. When they open the circuit these breakers will flash the lights and reset as you describe after you turn the switch off. This issue can be caused by several things and these are .....a direct short to ground in the circuit, fatigued breaker inside the switch, a bad connection at the switch (which will transfer heat inside to the breaker it self) and an overloaded circuit that is caused by the addition of more lights than the circuit will tolerate etc. If ALL of your lights are working correctly for a period of time before the breaker starts to open the circuit I would suspect in your case a fatigued breaker or a bad contact at the switch itself. Of course the problem needs to be thought out and diagnosed carefully. Let us know what you find and of course we have any parts available that you may require for the repair.

Sincerely,

Bill