« No Heat In The 87 Town Car | Main | Questions On Removing Trim On A 1973 Continental »

1978 Town Car Blower Issues

Hi Bill,

I have two beauties. A 1979 Town Car in need of some body work, and a 1978 that's as close to perfect for a 33 year old survivor. When I got the 79, the blower motor only worked on high, and after some research, I found it was as simple as the air conditioner fuse. Replaced it, and she blew as cold as she could, at all speeds.

My problem is I just bought the 78 and same issue. I figured "no problem. Replace the fuse when I get her home, and she'll work". Nope. No go. I did not have a circuit tester, so I swapped out the under hood/firewall mounted resisters and tested. Still only high fan. Have you seen this before? Could the issue be with the fuse box?

Perplexed,

Marc

---------------------------------------------------------------------------------------------------------------

Hi Marc -

Your blower problem is a common complaint item on many cars as they age. The most common failure in the blower circuit on your Lincoln is the High Blower Relay or its connections which are located under the hood on the firewall.

At Lincoln Land we would usually start diagnosing in this easy to access area. When the high speed is engaged it sends battery power direct to the blower through a fuse link. When the lower speeds are selected the relay hands off the circuit to its lower contacts and the blower switch and resistor circuit. A test light and a shop manual are usually a requirement to quickly diagnose this circuit. If necessary we can rebuild these relays for you. Let us know if you need any further advice or possibly a set of shop manuals for this and any future repairs.

Sincerely,

Bill